URI Online Judge | 1064
Positives and Average
Adapted by Neilor Tonin, URI Brazil
Timelimit: 1
Read 6 values that can be floating point numbers. After, print how many of them were positive. In the next line, print the average of all positive values typed, with one digit after the decimal point.
Input
The input consist in 6 numbers that can be integer or floating point values. At least one number will be positive.
Output
The first output value is the amount of positive numbers. The next line should show the average of the positive values typed.
Input Sample | Output Sample |
7 -5 6 -3.4 4.6 12 | 4 valores positivos 7.4 |
#include<stdio.h>
int main()
{
int i,pos=0,neg=0;
double avr,a,b=0;
for(i=1;i<=6;i++)
{
scanf("%lf",&a);
if(a>0){
b+=a;
pos++;
}
avr=b/pos;
}
printf("%d valores positivos\n",pos);
printf("%.1lf\n",avr);
return 0;
}
Comments
Post a Comment